• 因近日遭受攻击,百科现已限制新用户的编辑权限,一段时间后成为自动确认用户方可编辑。

Difference between revisions of "Essentials"

From Minecraft插件百科
Jump to: navigation, search
(部分修改并精简显示内容)
m (错误内容修复)
Line 30: Line 30:
 
===命令===
 
===命令===
 
本目录下内容较多,请前往子页面查看
 
本目录下内容较多,请前往子页面查看
]]Essentials/Command]]
+
[[Essentials/Command]]
  
 
===权限节点===
 
===权限节点===

Revision as of 18:49, 15 March 2016

Bukkit/Spigot插件资料
插件名称 Essentials
最新版本 2.14.1.3
兼容服务端 1.7.9-R0.1
源地址 http://dev.bukkit.org/bukkit-plugins/Essentials

子页面部分内容取自john180原创教程,已获得作者许可。

Essemtials官方图标
Icon-info.png
本页面已存在其他语言的内容,请协助翻译为本地化的中文。
  • 点击此处开始翻译。
  • 如本模板出现在原文存档页面,请注意更新主页面后,仍需要去除此处该模板
  • 如当前页面已经没有需要翻译的内容,请删去待翻译模板
  • 有标题的大篇幅文章,如果短时间内无法全部翻译,请先把所有的标题翻译出来,以便
  • 之后的贡献者选择与翻译章节内容。

简介

Essentials提供超过100个有用的命令给几乎所有的服务器
Essentials事实上是按标准为MineCraft服务器建立的,从小型服务器运行在台式机,VPS主机和专用的Minecraft的服务器
Essentials是有史以来最受欢迎的Bukkit插件,从所有小的个人Windows服务器主机,到巨大的超过500+槽的Linux服务器主机 Ess.png

安装

下载:跳转到Downloads页面 安装方法:

  1. 关闭服务器
  2. 打开plugin文件夹
  3. 放入Essentials核心
  4. 选择你想要的分项并放入
  5. 启动服务器
  6. 安装完成!

相关

|GorupManager|是一个权限管理插件。 利用它,你可以创建VIP用户或者做些其他的好玩的事情。 它也是大部分服务器常用的插件,甚至比Essentials还多。

维基

原地址

Essentials是由多个组件组成的,你应该把这些放在你的Bukkit/Minecraft插件文件夹中.你一般不需要/想要所有的组件,忽略你没有安装的组件的命令或权限.
如果你不知道每个组件是干什么的,那么查看Essentials/分解
权限不会自动包容字权限,你需要权限'essentials.spawnmob'以及'essentials.spawnmob.wolf' 或 'essentials.spawnmob.*' 才能去使用命令"/spawnmob wolf".

命令

本目录下内容较多,请前往子页面查看 Essentials/Command

权限节点

本目录下内容较多,请前往子页面查看 Essentials/Permissions

配置文件

本目录下内容较多,请前往子页面查看 Essentials/配置文件

常见问题及其解答


原地址

Bukkit


在哪里我可以获得CraftBukkit的最新版本?

这里获取

这是你一直可以找到最新的推荐版本的craftbukkit. 请记住,CraftBukkit的更新很快,时常可能会获得更好的对插件的兼容性,所以使用推荐的版本总是最好的, 其他CraftBukkit版本可能有一些错误或者你没有意识到的兼容性问题,和不支持很多开发商的插件,有些插件可能只依靠推荐的版本来设计.


我怎么知道CraftBukkit和Essentials的版本?

如果你从上面的连接下载了CraftBukkit,你应该知道他的版本. 如果你看着控制台,那么他会告诉你所有插件的版本.


多久我要升级一次我的插件和CraftBukkit

不同的人会有不同的方法, 但你在任何时间都应该经常升级CraftBukkit和你的任何插件. 插件总是基于最新的版本更新, 所以安装一个新版本的插件和一个旧版本的CraftBukkit很可能会出错.

Essentials


我如何去修改原本的十秒传送冷却?

这个设定这Essentials的config.yml中. 找到这一行: teleport-delay: 10
数字10则为传送冷却时间设置,你可以设置到一分钟(60)或者关闭它(0) teleport-delay: 0
如果他不在这里,那么你这需要添加这一行即可.


Essentials使用了一个错误的语言.我如何去修改它?

这个设定同样在config.yml,在这里找到更多区域的语言并设置他.


我如何使它如此不同的用户有不同的颜色名称?<

你可以配置Essentials去个性化名字和聊天格式.在这里找到更多聊天格式.


如果在起点插件时你获得一个'UnsupportedClassVersionError(不支持的类的版本错误)'错误,这是什么?

这个错误提示同城意味着你运行了一个旧的无法支持的Java版本.你需要新的Java6去运行Essentials.更多信息在这里.


在升级到EssentialsChat2.9.2我无法设置我的后缀及无法发出有颜色的信息!

在我们的错误的地方,你可以使用后缀设置插件的颜色信息,造成的问题是固定的。而不是使用格式中的要点config.yml添加消息的颜色.


我不能在2.9版本中创建某一类型的牌子!

在2.9.所有的牌子都是默认不能使用的.大约在264行开始的"enabledsigns"部分。删除你想使用的牌子钱的符号“#”,这样你就可以使用了.

Group Manager


我如何给与某个玩家或某个组使用某个命令的能力?

Essentials和GrupManager插件是打包安装的. 想要了解如何解决这个问题的方法, 查看GroupManager指南.


这个组的配置一直保持重载, 我如何去改变他?

GroupManager 它每10分钟的重新载入一次.如果你想要做出改变,你可以禁用自动保存,或者请求手动重载/ manload
See also: Group Manager/Config

YAML


当我运行服务器时, 发现了YAML错误?

如果服务器发送了一个YAML错误到服务器控制台提示这是错误的. 那么这通常是你突出了一格而被认为这是错误的,亦或是检查拼写错误或者缩进的错误.
如果你发现了一格日志写着'\t',然后你使用了标号.替换任何你有四个空格的标号.
如果你还需要帮助就来IRC吧(IRC,Internet Relay Chatting , Internet 在线聊天系统)

Migration


在Essentials中,我可以使用以前的warp.yml吗?

如果你的warp文件保存到了。txt格式你可以复制它到plugins/Essentials文件夹然后它就会重载,但是在这个时候你没有办法转换MyWarp文件。


我当前使用着一个权限系统,我还可以使用Essentials吗?

Essentials是由PermissionBukkit/PermissionsEx/BukkitPermissions和其他权限系统组成的,你只需要添加正确的权限节点和保证你没有 EssentialsGroupMananger.jar和EssentialsGroupBridge.jar。你可以把它变成为Essentials预设置的GroupManager.

教程

本目录下内容较多,请前往子页面查看。 Essentials/教程

脚注

Copyleft.png
该作者已授权以 署名-相同方式共享 (by-sa) 方式使用其作品