• 欢迎来到Minecraft插件百科!
  • 对百科编辑一脸懵逼?帮助:快速入门带您快速熟悉百科编辑!
  • 因近日遭受攻击,百科现已限制编辑,有意编辑请加入插件百科企鹅群:223812289

MagicSpells/商店

From Minecraft插件百科
Revision as of 09:22, 12 January 2018 by Qsefthuopq (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

商店插件允许你来用告示牌售卖技能和卷轴。

下载

访问原页面的“Download”处进行最新版的下载。

安装和配置

要使用本附属插件,必须先安装以下插件:

  • MagicSpells本体(必须)
  • Vault插件(如果需要)
  • 任何一个和Vault相配合的经济插件(如果需要)

安装只需放入plugins文件夹中,插件目录会生成一个config.yml配置文件,详情如下:

选项 解释 默认值
require-known-spell 玩家创建魔法商店是否需要玩家已经学会该魔法. true
require-teach-perm 放置牌子的玩家是否需要传授麦佛啊的权限来创建魔法商店. true
currencies 列出可使用的名称和货币. 第一行是默认货币, in case one isn't listed on the sign. 有效的数值有 “vault”普通的经济支持 , “levels” 经验等级, “experience” 经验, 和物品ID (例如: “266”), 或物品ID和子ID结合 (例如: “351:3”).
first-line 魔法商店牌子第一行显示的信息. [SPELL SHOP]
str-already-known 玩家已知该魔法时显示的信息. You already know that spell.
str-cant-afford 玩家买不起卷轴时显示的信息. You cannot afford that spell.
str-purchased 当玩家成功购买魔法时显示的信息. You have purchased the %s spell.
first-line-scroll 卷轴商店牌子第一行显示的信息. [SCROLL SHOP]
scroll-spell-name 魔法卷轴的内部名称. scroll
scroll-item-type 卷轴材质 (默认是纸). 339
str-cant-afford-scroll 玩家买不起卷轴时显示的信息. You cannot afford that scroll.
str-purchased-scroll 当玩家成功购买卷轴时显示的信息. You have purchased a scroll for the %s spell (with %u uses).
str-scroll-fail 插件创建卷轴失败时显示的信息 . You cannot purchase a scroll at this time.

字符串中变量意义:

  •  %s: 技能名
  •  %c: 购买费用
  •  %u: 使用次数(仅对于卷轴商店)

权限

你必须拥有magicspells.createsignshop权限点才能创建一个技能商店,这个权限点是管理员默认拥有的。

用法

创建技能商店,只需要这样写告示牌:

  • 第一行:[SPELL SHOP](即配置文件中的first-line的值)
  • 第二行:魔法名称
  • 第三行:花费(必须是此格式:- <数额> [货币单位] - 举例: 10 gold)
  • 第四行:此行随便什么文本都行

创建卷轴商店,只需要这样写告示牌:

  • 第一行:[SCROLL SHOP](即配置文件中的first-line-scroll的值)
  • 第二行:魔法名称
  • 第三行:使用次数(例如:“5 uses”)(只能是数字+任何文本)
  • 第四行:花费(必须是此格式:- <数额> [货币单位] - 举例: 10 gold)

默认设置

require-known-spell: true
require-teach-perm: true

currencies:
    money: "vault"
    levels: "levels"
    xp: "experience"
    gold: "266"
    cocoa: "351:3"

first-line: [SPELL SHOP]
str-already-known: You already know that spell.
str-cant-afford: You cannot afford that spell.
str-cant-learn: You are not able to buy that spell.
str-purchased: You have purchased the %s spell.

first-line-scroll: [SCROLL SHOP]
scroll-spell-name: scroll
scroll-item-type: 339
str-cant-afford-scroll: You cannot afford that scroll.
str-purchased-scroll: You have purchased a scroll for the %s spell (with %u uses).
str-scroll-fail: You cannot purchase a scroll at this time.

论坛

如果对于此插件有任何疑问,请前往作者论坛查询或发帖。(英文)