Wiki赞助.jpg
  • 欢迎来到Minecraft插件百科!请在注册后加入百科编辑
  • 对百科编辑一脸懵逼?帮助:快速入门带您快速熟悉百科编辑!
  • 插件百科企鹅群:223812289

Difference between revisions of "Ymer"

From Minecraft插件百科
Jump to: navigation, search
Line 33: Line 33:
 
* 兼容Valkyrie-1.2和1.3 √
 
* 兼容Valkyrie-1.2和1.3 √
 
:(虽然Valkyrie-1.3还没有发布出来)
 
:(虽然Valkyrie-1.3还没有发布出来)
 +
== {{MCColor|&6|计划}} ==
 +
* 支持32位Windows操作系统 √
 +
* 支持64位Linux操作系统 √
 +
* 增强反作弊功能(文件查找功能增强) √
 +
* 反JavaAgent作弊 √
 +
* 支持材质包检测 ×
 +
* 提供配置文件 √
 +
* 支持1.6.4版本的服务端 ×
 +
* 支持Sponge服务端
 +
* 反注入 √
 +
* 支持Cuberite服务端 ×
 
= {{MCColor|&e|兼容性}} =
 
= {{MCColor|&e|兼容性}} =
 
目前为止,Ymer兼容以下服务端核心:
 
目前为止,Ymer兼容以下服务端核心:

Revision as of 12:37, 23 February 2018

「Ymer」 | 保护您的服务器免受作弊玩家的侵扰

Bukkit/Spigot插件资料
插件名称 Ymer
最新版本 1.1.6
前置插件 无前置插件
兼容服务端 Cauldron 1.7.10/Bukkit 1.7.10 - 1.12.2及更多
作者 lona
源地址 http://www.mcbbs.net/thread-778861-1-1.html

———————— Ymer插件Wiki ————————

欢迎阅读此Wiki | 插件发布地址

—————————————————————————

简介

Ymer 是一款配合客户端MOD使用的反作弊插件,其最大特点是代码90%以上均由C++编写且目前可支持32位/64位Windows操作系统以及64位Linux系统

功能

能/不能防御的作弊

  • 所有基于MOD的作弊 √
  • 大部分已知的作弊端 √
  • javaagent作弊 √
  • 透明材质包 ×

优/缺点

  • 破解难度更高 √
纯java编写的反作弊容易被反编译,反混淆,而C++就从根本解决了这个问题(虽然也有反编译)
  • 速度快 √
  • 资源占用少 √
本插件占用的内存和CPU可以忽略不计
服务端内存占用为每玩家8kb(就算1000个玩家在线也才8M内存)
客户端内存占用不大于40M
  • 容易报毒 ×
虽然库是用C/C++写的,但是国产杀软是真的厉害
  • 兼容Valkyrie-1.2和1.3 √
(虽然Valkyrie-1.3还没有发布出来)

计划

  • 支持32位Windows操作系统 √
  • 支持64位Linux操作系统 √
  • 增强反作弊功能(文件查找功能增强) √
  • 反JavaAgent作弊 √
  • 支持材质包检测 ×
  • 提供配置文件 √
  • 支持1.6.4版本的服务端 ×
  • 支持Sponge服务端
  • 反注入 √
  • 支持Cuberite服务端 ×

兼容性

目前为止,Ymer兼容以下服务端核心:

  • CraftBukkit
  • Spigot
  • PaperSpigot
  • HoseSpigot
  • TacoSpigot
  • TorchSpigot
  • Sponge(Pore)
  • Cauldron
  • KCauldron
  • Uranium
  • GlowStone

工作原理

Ymer依赖libymer检测客户端运行时载入的文件,如果该文件不在SHA512.txt列表中则会踢出玩家
Note:SHA512.txt文件中是所有允许使用的MOD与一些库文件的集合

安装方法

  • VPS服务器安装方法:
  1. 解压文件
    1. 解压刚刚下载完的Ymer-x.x.x[1].zip文件
  2. 客户端安装
    1. 打开解压出来的Ymer-x.x.x文件
    2. Note:如果你的客户端和服务端是1.7.10版本,那么请选择ymer-x.x.x-1.7.10.jar,如果你的客户端和服务端在1.8.X - 1.12.X版本内,请选择ymer-x.x.x-1.8.X.jar
    3. 找到libymer32.dll、libymer64.dll文件和ymer-x.x.x-y.y.y[2].jar文件,将这三个文件移动至客户端的mods文件夹内
    4. 启动客户端,然后关闭
  3. 服务端安装
    1. 打开解压出来的Ymer-x.x.x文件
    2. 找到ymer-x.x.x-y.y.y.jar文件,将文件移动至服务端的plugins文件夹内
    3. 启动服务端
    4. Note:服务端初次安装Ymer时,启动后会因为没有libymer文件和SHA512文件的依赖而关闭服务器,这个情况纯属正常
  4. SHA512文件配置
    1. 打开客户端的mods文件夹上一级目录
    2. Note:通常的mods文件夹上一级目录是.minecraft文件夹,也有些是.minecraft/versions/x.x.x[3]-forgey.y.y[4]-z.z.z.z[5]/
    3. 找到SHA512.txt文件,将文件移动至服务端的plugins/ymer/文件夹内
  5. 库文件安装
    1. 请根据你服务器的操作系统将libymer32.dll、libymer64.dll或libymer.so放在服务端的 plugins/ymer/ 文件夹中(dll对应Windows操作系统,so对应Linux操作系统,32对应32位,64对应64位,Linux操作系统只支持64位),不清楚可以全部放入。如果你的服务器是Linux操作系统,请将libymer.so放在服务端的 plugins/ymer/ 文件夹中并自行安装mbedtls库和libiconv库,不想安装mbedtls库和libiconv库也可以将libmbedtls.so,libmbedcrypto.so,libmbedx509.so,libiconv.so复制到服务端的 plugins/ymer/ 文件夹中
    2. 启动服务端
  • 面板服务器安装方法:
  1. 检查操作系统
    1. 询问服务商获取操作系统版本(是Windows还是Linux)
  2. 安装
    1. 同上面的VPS服务器安装方法一样(注意Windows的库文件叫做libymer32.dll libymer64.dll,Linux的库文件叫做libymer.so,如果服务器没有安装mbedtls库和libiconv库,那么将无法在Linux正常工作)
    2. 如果不想安装mbedtls库和libiconv库,请将Ymer-x.x.x文件中的libmbedtls.so,libmbedcrypto.so,libmbedx509.so,libiconv.so放入服务端plugins/ymer文件夹中

配置文件

  • 验证超时的时间(单位:秒)
  • 超时时间建议设置为默认,不作修改

脚注

  1. x.x.x:Ymer插件的版本
  2. y.y.y:插件支持的版本
  3. x.x.x:客户端的版本
  4. y.y.y:客户端的版本
  5. z.z.z.z:Forge的版本